dpkg: 处理软件包 xxx (--configure)时出错解决方法

dpkg: 处理软件包 xxx (--configure)时出错解决方法

DONG HAO
2022-10-11 / 0 评论 / 439 阅读 / 正在检测是否收录...
温馨提示:
本文最后更新于2022年10月11日,已超过614天没有更新,若内容或图片失效,请留言反馈。
dpkg: 处理软件包 xxx (–configure)时出错:
依赖关系问题 - 仍未被配置

dpkg: 依赖关系问题使得 xxx 的配置工作不能继续:

xxx 依赖于 libicu-dev;然而:

软件包 libicu-dev 尚未配置。

解决方法:

#先切换到root用户
sudo su                 

mv /var/lib/dpkg/info  /var/lib/dpkg/info_bak

mkdir /var/lib/dpkg/info

apt-get update && apt-get -f install 

mv /var/lib/dpkg/info/*  /var/lib/dpkg/info_bak/

rm -rf /var/lib/dpkg/info

mv /var/lib/dpkg/info_bak /var/lib/dpkg/info

完成

0

评论 (0)

取消